Scott Hardie | April 29, 2003
I've looked for help on this subject online, but to no avail, so I turn to you for assistance. I normally have my Internet Explorer windows maximized, but on the occasions when I don't, they're small square windows, about 60% the width and height of the total resolution. I fucking hate it when the window is not maximized, but is sized to 100% of the screen, so it looks like it is maximized. My brain thinks it's maximized, so when I go to close it, I click the absolute upper-right corner, and this only closes the maximized window beneath it. (My mother leaves her windows this size, so I have to be especially careful on her computer.)

Anyway, lately on my computer, IE has been auto-resizing to that 100% window size without actually maximizing. It keeps happening on the same sites. First it happened whenever I visited the homepage, which has a lot of Java crap on it, so I thought it was just a fluke there. But now it happens at,, even here on Tragic Comedy. I don't know what's causing it. Say I have an IE window at 60% screen width, and I maximize it. Then when I visit a site while maximized, the whole computer (save for the mouse cursor) will lock up for about 2-4 seconds, and the window size button (beside the X in the upper-right corner) will darken as though it's disabled, then the window will open the page and the button will lighten again. But if I then click that button to restore down, the window will be at 100% instead of 60% like it was a minute earlier. This is apparent whenever I open new windows, which is constantly. They all open at 100%, obscuring the window beneath, which is why I open new windows (because I'm not done reading the old one), and it's very irritating.

I've already tried holding CTRL to save the window size, no good. And I know of programs that will force IE to be maximized at all times, but sometimes I want 60% windows. I just want IE to stop auto-resizing itself to 100% windows. The only explanation I have is that the problem started about six weeks ago when I restored my security settings - I had fiddled with them for a few days, disliked the changes, and set them back to medium for everything. Suggestions please?

Scott Hardie | April 29, 2003
And another problem that may be related: IE has gotten excessively sluggish lately. That 2-4 second delay doesn't just happen when it's auto-resizing. If I right-click on a link, it takes a second to open the menu options. If I move the cursor over a picture, it takes a few seconds to make the caption appear, then another two seconds to remove it when I remove the cursor. When I click on "Favorites," it takes a few seconds to make the list appear. And when I say it takes a few seconds, I mean that the entire program freezes, animated gifs and everything, while it's carrying this out. This is a brand new computer, 3.5 gigahertz, and the problem only started within the past few weeks, so I don't think it's a hardware problem. Please give me any advice you can; this is really bothering me.

Scott Hardie | May 3, 2003
New on my list of attempted solutions that failed to work: Defragmenting my hard drive, setting my internet security settings to none, deleting the entire contents of my temporary internet folder, and restoring all of the IE settings to default. No good. I can't hold it against you all if you can't help me, since I obviously couldn't help someone with this problem if they asked me.

Anna Gregoline | May 3, 2003
I really have no clue, Scott. Honestly.

Matthew Preston | May 4, 2003
Are you using the new Windows XP mode or classic mode to display the windows? I have heard instances of your particular problem in the new XP mode. My IE window in classic mode will open in the size that it was previously closed in, no ctrl holding needed.
The other symptoms you are describing sound a lot like spy-ware issues. If your internet connection is sluggish you could have some hacker programs eating away at your bandwith and resources. I can supply you with the program Ad-Aware that will eliminate spy-ware and tracking cookies and programs. It may help. Also, if you are using any firewall (such as zonealarm) have it ask you for access any time a program attempts access to the internet. If your kernel32 or other programs without a name are asking for access, you may be infected.
To speed up access to pages, click on "Internet Options", Click the "Settings" button under "Temporary Internet Files" and set the "Check for newer versions of stored pages" to "Automatically". Your IE files could also be corrupted. Check for newer versions or security updates at When you update, it generally replaces any incorrect files. If there is still no effect, your computer could simply use a good wipe out and reset from scratch. I would recommend utilizing a "clean" version of Windows XP (One that is not from a third party vendor such as Gateway, etc.) That's all the ideas I've got.

Scott Hardie | May 5, 2003
Thanks Matt. The window-resizing issue seems to have gone away (my fingers are crossed), but the slowdown issue persists. I was bored about three months ago, so I dug out all my CD-ROMs of TrueType fonts (some of them dating back to the Windows 3.1 days) and I installed about a thousand of them; that may be causing the sluggishness.

Want to participate? Please create an account a new account or log in.